WYSIWYG-/CK-Editor Control/Setting

  • Hallo zusammen,


    Ich möchte in meiner site.xml gerne eine Text-Einstellung mit Formatierung anbieten.

    Dafür wollte ich das WYSIWYG-/CK-Editor Control benutzen.

    Wenn ich allerdings versuche dieses einzubinden kommt es zu Fehlern:

    XML: settings.xml
    1. <input conf="event.settings.1234" data-qui="controls/editors/Editor">
    2. <description>
    3. <locale group="quiqqer/calendar" var="sitetypes.event.settings.details"/>
    4. </description>
    5. </input>

    So wird einfach nichts angezeigt.

    Verwende ich stattdessen data-qui="package/quiqqer/quiqqer/bin/QUI/controls/editors/Editor" bekomme ich einen JS Fehler: TypeError: Cls is not a constructor


    Was mache ich falsch, bzw wie macht man es richtig?



    Danke schon mal im Voraus.

  • Also ich hab das bei mir gerade getestet. Das funktioniert einwandfrei. Ich habe sogar dein Schnipsel direkt bei mir einmal eingebaut. Der Editor wurde geladen.

    XML: site.xml
    1. <input conf="event.settings.1234" data-qui="controls/editors/Editor">
    2. <description>
    3. <locale group="quiqqer/calendar" var="sitetypes.event.settings.details"/>
    4. </description>
    5. </input>




    Das wäre die richtige Vorgehensweise. Du redest aber einmal von settings.xml und einmal von site.xml, also in beiden habe ich es getestet und der Editor wurde ohne Probleme geladen.

    Wie alt ist denn deine QUIQQER Installation?

  • Hab's jetzt nochmal probiert, jetzt wird zumindest versucht der Editor zu laden.

    Allerdings bekomme ich in der Console einige Fehler:




    Meine QUIQQER-Installation ist noch nicht so alt (max. 3 Monate) und die neuesten Updates sind installiert.

  • Wir haben vor kurzem eine große Versionsänderung beim CKEditor gehabt.


    Dabei kam es manchmal zu Fehlern bei einem bestimmten Updateprozess.

    Diese sind inzwischen aber behoben, allerdings sieht es so aus, als wär dein System noch "verunreinigt" :)


    Um dies zu behoben führe bitte folgende Schritte durch:

    • Wechsle in das Root-Verzeichnis deiner QUIQQER Installation.
    • Benenne den Ordner var/package/quiqqer/ckeditor4/plugins um. Zum Beispiel in plugins.bak
    • Führe ein QUIQQER Setup aus: Im QUIQQER Root-Verzeichnis php quiqqer.php setup
    • Dadurch sollte der Plugin Ordner wieder angelegt und befüllt werden und der Editor sollte die Plugins korrekt laden und dargestellt werden.

    Falls diese Schritte das Problem nicht beseitigen melde dich bitte nochmal.

  • Hey, vielen Dank für deine Hilfe!


    Diese Schritte bin ich gestern schon mit Henning durchgegangen. Der Plugin-Ordner ist jetzt auch wieder korrekt vorhanden, allerdings wird der Editor immer noch nicht korrekt angezeigt.


    Der Editor wird zwar geladen, wie am HTML-DOM zu erkennen ist, allerdings wird er nicht richtig (zu geringe Höhe) angezeigt.


    Falls du jetzt spontan keine Idee hast, woran es liegen könnte, dann warte ich erst mal ab bis nächste Woche und suche den Fehler mit Henning , wenn ich noch mal im Büro bin.

  • Also, das Problem ist behoben. Waren nun mehrere Sachen.

    Einmal der Editor wurde in die Settings geladen, dafür ist der Editor nicht geeignet. Das wurde nun unterbunden und der Editor muss immer in einer neuen Panel Kategorie angezeigt werden.


    Zusätzlich haben wir glaube ich die Toolbars von ihm geleert. Er hat WYSIWYG Module geladen die aber nicht aktiviert waren :-)